Receiving Specified Resource Not Found Error

Issue/Question

When a student clicks on a file in a course, they receive an error message that says:

The specified resource was not found, or you do not have permission to access it.

When the instructor clicks the file, they can access it without issue.

Cause

There is a file permission issue that is denying access to students.

Resolution

Blackboard administrators will need to correct the permission issue and grant access to the students. Please contact the ITS Service Desk.

ITS Service Desk Consultants Only

Fill out ticket template Software and Enterprise Systems > Blackboard > General Problem or Issue and route to Application Support & Web Dev.

 

Blackboard Administrators Only

If the issue affects one or more files that exist in the current course files folder, update the permissions on the course files folder to include students for the course in question.

  1. Emulate the instructor's account.
  2. Navigate to the course files folder in question.
  3. Edit the folder's permissions.
  4. Go to Select Specific Users by Place --> Course.
  5. Under Choose Courses, check the box for the course in question.
  6. Under Select Roles, check the box for Student.
  7. Under Set Permissions, check the box for Read.
  8. Under Advanced Folder Options, check the box for Overwrite.
  9. Submit.

If the issue affects one or more files that do NOT exist in the current course files folder, update the link to the file so the permissions will be updated.

  1. Copy the desired file from the previous course's course files folder to the current course's.
  2. Edit the item/assignment/etc in the current course site.
  3. Add a link to the proper file.
  4. Remove the link to the file with permissions issue.
  5. Submit.

Details

Article ID: 1849
Created
Tue 10/20/15 10:06 AM
Modified
Wed 11/6/19 3:18 PM