Hold for Authentication Displaying in Printer Queue (macOS)

Issue/Question

When I try to print something, the document stays in the queue on my Mac with a message:

Hold for Authentication.

Cause

Departmental printers are restricted by Active Directory groups, which are tied to NetIDs. If your account has recently updated (password changed, moved departments, etc.) the macOS operating system updates and allows you to login, but the information stored about the printer is not updated.

Resolution

Sometimes rebooting the computer can resolve this problem. Please reboot the computer and try printing again. If the problem persists, please continue with the steps below.

  1. Click  (Apple menu item).
  2. Select System Preferences... .
  3. Click  Printers & Scanners.
  4. Select the printer in the left pane.
  5. Click Open Print Queue... in the right pane.
  6. Remove any documents in the queue.
  1. In the top-right corner of the screen, click  (Spotlight).
  2. Enter Keychain.
  3. Select Keychain Access.
  4. Click All Items.
  5. Click Search.
  6. Enter the name of your printer (e.g. PS1-PS1-RICOHMPC###-JRH-300, or PS-MPS-RICOHSP###-JRH-300).
  7. Right-click the entry for the printer.
  8. Select Delete "___".
  9. Click Delete.
  10. Return to the document and print it again.
  1. In the top-right corner of the screen, click  (Spotlight).
  2. Enter Printers.
  3. Select Printers & Scanners.
  4. Select the printer in the left pane.
  5. Click Options & Supplies... in the right pane.
  6. Take note of the Device Name field.
  7. Click  (Spotlight).
  8. Enter and select Terminal.
  9. Enter this command: lpadmin -p printer_queue_name -o auth-info-required=username,password, replacing printer_queue_name with the information in the Device Name field from above.
  10. The next time you print, you will be prompted for your account credentials, and to store them in the keychain if desired. Once submitted, the content should print.
If the document still does not print, the printer may need to be deleted from the computer and re-added. See the related articles for assistance.

Details

Article ID: 3126
Created
Mon 10/1/18 4:19 PM
Modified
Tue 4/20/21 10:08 AM