Hold for Authentication Displaying in Printer Queue (macOS)

Issue/Question

When I try to print something, the document stays in the queue on my Mac with a message:

Hold for Authentication.

Environment

  • WKU-owned macOS devices

Cause

Departmental printers are restricted by Active Directory groups and NetID authentication. Printers setup by ITS prior to July 2021 used a method that could break the communication between the computer and the device when a macOS update is installed.

Resolution

  1. Click  (Apple menu item).
  2. Select System Preferences... .
  3. Click  Printers & Scanners.
  4. Select the printer in the left pane.
  5. Click (Delete printer).
  1. Click  (Spotlight).
  2. Search for Self-Service.
    Note: If your WKU-Owned Mac does not have the Self-Service app, it is not enrolled in our Device Management system. See this article to add the computer.
  3. Open the Self-Service app.
  4. In the left pane of the window, click  Your Printers.
  5. Locate your area's printer(s) and click Install Now.
    Note: If your area's printer(s) is not listed, please contact the ITS Service Desk to request it be added.
  6. Within a few moments, the new version of the printer(s) will appear in your Printers and Faxes list.
  7. Return to the document and print it again.