b (bold) element used

Issue/Question

When I run a Page Check I get the following Known Problem: b (bold) element used.

Environment

  • Omni CMS

Cause

Omni CMS Final Checks look over all the code on a page and detect accessibility issues that do not meet WCAG 2.0 (Level AA) standards. It has detected that the page contains bold text using the b element. In HTML, the b element can be used to bold text, but is not handled as well by screen readers as the strong element. The WYSIWYG editor uses the strong element for bold text, but your page may have an old b tag from a previous editor or pasting content in from a text editor like Microsoft Word.   

Resolution

Any b element on your page must be replaced with the strong element, by removing formatting and adding bold back using the WYSIWYG editor toolbar.

  1. Check out the page if it is not already.
  2. Click the  Edit tab.
  3. Click the  Edit Button on the content area where the bold text is located.
  4. Highlight the italicized text that was identified in the Source Code section fo the page check.
  5. In the WYSIWYG toolbar click the  Clear Formatting button to remove the style.
  6. With the text still highlighted, click the bold button the in toolbar to create the correct strong element instead.
    Note: You can also use the semi-bold text option in the style drop down to bold text.
  7. Save the page.
  8. Click the Publish button to run the accessibility final check again. Repeat the steps as necessary to replace bold text. When the issue has been resolved it will no longer display in the accessibility check.

Details

Article ID: 3738
Created
Tue 2/9/21 1:25 PM
Modified
Mon 8/15/22 9:50 AM