Body
Issue/Question
My student email has suddenly stopped working on mobile devices or my password has suddenly stopped allowing me to sign in.
Environment
Cause
Student email accounts are hosted by Microsoft 365, and Microsoft requires that all passwords expire every 2 years. If the account password has expired, it may prevent you from signing in or checking email on your connected devices.
Resolution
Visit the Manage My WKU Accounts website to change your student email password. This will allow you to sign-in to webmail immediately. If the password is still rejected on your mobile device, wait 24-hours for the systems to synchonize and try again.