ILL Error: Unable to Process Your Request

Issue/Question

When I try to log in to the Online Interlibrary Loan system, I receive error:

We’re sorry. We are unable to process your request at this moment. Please try again later.

Environment

Cause

This message indicates there could be an issue with your browser cookies or cache.

Resolution

Please see the related article for clearing cookies and cache for the browser you are using. If you need additional assistance, please contact the ITS Service Desk or submit a service request.

Details

Article ID: 2657
Created
Fri 4/7/17 9:43 AM
Modified
Fri 12/15/23 1:13 PM

Related Articles (3)

Instructions for clearing cache in a browser.
Information about problems accessing the Online Interlibrary Loan System.
Information regarding WKU Interlibrary Loan (ILL) systems.