Body
Issue/Question
When I plug in my external drive, it is not recognized.
Cause
Data on the drive may be corrupted or the drive itself may be failing.
Resolution
- Disconnect the drive.
- Connect it to a different port on the computer, if available.
- If the drive is recognized and usable, the port previously used may be underpowered.
- If the drive is recognized, but not usable, the data may be corrupted. Reference the related article, Formatting a USB Flash Drive, for assistance in removing all data from it.
- If the drive is still not recognized, it may be failing. If possible, connect the drive to a different computer to ensure the computer in use is not at fault.
- If the drive is not recognized on another computer, contact the manufacturer to see if the drive is still under warranty and can be replaced.