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Issue/Question
When I try to open the Respondus Lockdown Browser I receive this error message:
Update server is not supplying information, or the connection to update server is blocked. Please try again later.
Cause
There are many possible reasons for receiving this message, e.g. a network connection error, a conflicting proxy setting, or an application blocking access to the Respondus servers.
Resolution
- Ensure your network connection is working properly. Reference the Related Article, Receiving No Network Connection, for assistance.
- To check for proxy settings, reference the applicable Related Article, Clearing Proxy Server Settings, for your operating system.
- Add the following addresses to the Trusted Sites list on your computer to ensure the Respondus servers are not blocked. See Related Article, Adding Trusted Sites, for assistance.
- respondus2.com
- respondus.com
- static-public-downloads-cloud.respondus.com.s3.amazonaws.com
- If the issue persists, it is recommended to try using the Respondus browser either on a different computer or on a different network. This will help determine if the issue is specific to your computer or a broader issue that needs further investigation.
If the above steps do not resolve your problem, please contact the ITS Service Desk.