Issue/Question
When I browse to wku.edu/benefits/bf to complete the benefit enrollment process, I get a page with the following error after entering my NetID and password correctly:
We encountered an issue with your request. Your user was not able to be uniquely identified. Please close this window and try again or contact your originating site administrator.
Environment
- Top Life - Benefits
Note: This third-party system is also known by these other names:
- Benefitfocus
- HR In Touch (HRIT)
- Benefit Portal
- Benefit Enrollment/Change Portal
Cause
There is an issue with your third-party Top Life - Benefits account (not your WKU NetID). Typically the above error indicates the account has been locked by the third-party.
Resolution
Notify Western Kentucky University's Human Resources Benefits staff of the issue by emailing benefits@wku.edu with the error message and any other details that may be relevant. They will be able to resolve the issue on your behalf.