Error Logging Into Top Life Benefits

Issue/Question

When I browse to Benefits Portal to complete the benefit enrollment process, I get a page with the following error after entering my NetID and password correctly:

We encountered an issue with your request. Your user was not able to be uniquely identified. Please close this window and try again or contact your originating site administrator.

Environment

  • Top Life - Benefits
    Note: This third-party system is also known by these other names:
  • Benefitfocus
  • ​HR In Touch (HRIT)
  • Benefits Portal
  • Benefit Enrollment/Change Portal

Cause

There is an issue with your third-party Top Life - Benefits account (not your WKU NetID). Typically the above error indicates the account has been locked by the third-party.

Resolution

Notify Western Kentucky University's Human Resources Benefits team of the issue by filling out the Benefits Issue or Request form with the error message and any other details that may be relevant. They will be able to resolve the issue on your behalf.

Details

Article ID: 900
Created
Mon 11/10/14 7:40 AM
Modified
Fri 9/29/23 10:45 AM