Registering Error (Cisco Phones)

Issue/Question

My Cisco phone says Registering... and has no functionality.

Environment

  • Cisco Phones

Cause

The phone has lost connection to the WKU network.

Resolution

Try unplugging the cable in the back of the Cisco phone, and plugging the cable back in.

If the issue still persists, please contact the ITS Service Desk or submit a service request by clicking the Request Service button.

Request Service Print Article

Related Services / Offerings (1)

Do you have an issue or request involving a WKU network, Wi-Fi network, phone, voice, or cable television service?