Trouble Signing Into Parking & Transportation Permit Page

Issue/Question

I am unable to sign into the WKU Parking Permit portal even though I am able to sign into other NetID related websites such as myWKU.

Cause

You are either a new student or faculty/staff member and your credentials have not populated to the web server hosting the WKU Parking Permit page. New employees can take up to 2 weeks to populate in the Parking Permit system.

Resolution

You can receive help with this page by calling Parking and Transportation at 270-745-2361.

100% helpful - 1 review

Details

Article ID: 1728
Created
Tue 9/1/15 6:59 AM
Modified
Thu 7/30/20 12:26 PM