Issue/Question
My current printer or copier lease with a company other than Ricoh expires soon. How do I get set up for Managed Print Services?
Cause
Migrating to Managed Print Services.
Resolution
First, request a Managed Print Assessment. This will let our Managed Print Services team know that your lease is expiring and your department needs to transition to MPS. Meanwhile, contact the printer or copier vendor to request a month-to-month contract that can be canceled once you're migrated to Managed Print Services. For assistance working with vendors, contact Ashlee Tilford in Purchasing at 270-745-2909.