Issue/Question
When I go to the Manage WKU Accounts page, I receive the following error message:
For your security, your existing security question has expired. Before continuing, please contact the ITS Service Desk at (270) 745-7000, or by any of the methods listed on this page https://www.wku.edu/its/contact/.
Environment
Cause
WKU ITS identified several past security questions which were too easily guessed. Due to this security concern, ITS requires affected users to choose a different security question.
Resolution
For assistance with resetting your security question, please contact the ITS Service Desk.