Issue/Question
I cannot see all of my grades in My Grades.
or
When I open My Grades, my assignments briefly appear and then disappear.
Cause
A filter has been chosen in My Grades that is showing only Graded, Upcoming, or Submitted items.
Resolution
When My Grades is accessed from the notification menu the filter options are located on the right, below the course title, and above the grades section.
At the top of the page, there is a bar with the options All, Graded, Upcoming, and Submitted. Ensure that the All option is selected. If you still don't see your grades, they may have been hidden by your instructor. Contact your Instructor for assistance.