Issues with Pearson LockDown Browser

Issue/Question

How can I get course content in Blackboard to open with Pearson LockDown Browser?

Environment

  • Pearson LockDown Browser
  • Respondus LockDown Browser

Cause

Pearson LockDown Browser is a built-in lockdown browser through their learning system which is a third-party publisher. The Repsondus LockDown Browser is the WKU ITS supported lockdown browser and is available to install in WKU Blackboard. Sometimes the lockdown browsers will not work properly if both are installed.

Resolution

This article is provided only for your convenience. WKU Information Technology Services does not manage or support Pearson LockDown Browser (PLB). Please contact Pearson for further assistance. 
  1. Verify Pearson LockDown Browser and Respondus LockDown Browser are installed.
  2. Uninstall both browsers and restart the computer.
    Note: It is important that both browsers are uninstalled and the computer is restarted before continuing.
  3. Navigate to WKU Blackboard.
  4. Navigate to a course that requires Pearson LockDown Browser.  
  5. Download and install Pearson LockDown Browser.
  6. The Pearson LockDown Browser should work properly once launching course material.

Details

Article ID: 4056
Created
Sat 9/2/23 2:18 PM
Modified
Wed 10/18/23 3:10 PM