Laptop Not Charging

Issue/Question

My laptop is no longer charging or has intermittent charging issues.

Environment

  • WKU-Owned Machine
  • Enrolled Student Personally-Owned Device

Cause

There could be issues with the power cord, charging port or battery related issue.

Resolution

To be able to check-in the device through TopperTech, they must be WKU-Owned machines or student personally-owned devices
  1. Try using different power cords to verify if the problem is coming from the charger.
  2. Verify charging port appears to be in good condition. 

If issues still persist, please contact the ITS Service Desk or check-in laptop with TopperTech for a technician to diagnose the problem.

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Information on what to do when a desktop or laptop computer does not power on.