Parent Email Cannot be Updated by the User

Issue/Question

When I try to change my parent's email address in TopNet it gives an error saying the email cannot be updated by the user.

Cause

Students cannot personally update this information in TopNet and instead must contact either the Registrar's Office or Admissions to resolve this issue. 

Resolution

If you are a currently registered student, you must contact the Office of the Registrar.

If you are a current applicant or not currently registered, you must contact the Office of Admissions.