Issue/Question
When I attempt to delete an email message, it reappears moments later even though it was moved to deleted items. The email that reappears is often blank.
Cause
Multiple devices may be connected to the same account. If an item is deleted while the account is synchronizing to another device, the other device may upload the email to the server from it's cache. The email account may also have been added to the mail client using incorrect settings, which contributes to the issue.
Resolution
Remove the affected email account from all connected email clients. Add the account back to devices one at a time using the correct instructions for each type of account.