Testing Index.html File

Issue/Question

How do I determine if there is a problem with my index.html file?

Environment

  • People Server

Cause

Typos or accidental characters such as quotation marks or greater or less than symbols often get inserted into web code and cause strange behavior when viewed through a web browser. It can be hard to even know to look for such. By uploading a simple new index.html file, you can verify there are no server problems and that the issue lies with the code itself.

Resolution

When using the PeopleSpace server at WKU it is imperative that your index file by named precisely index.html in order for the PeopleSpace server to utilize the file. Other file names may not produce working results.
  1. Create backup of your original index.html file.
  2. Create new index.html file with following code only:

    <!doctype html>
    <html>
        <head>
            <meta charset="utf-8">
            <title>Test File</title>
        </head>

        <body>
            This is a test file!  If you can see this, your index.html is working!
        </body>
    </html>

  3. Upload newly created index.html file.
  4. Browse to your URL
  5. If you see the message This is a test file!  If you can see this, your index.html is working. and no other errors or characters, you know the problem lies in the code of your original file.  

If you need assistance, please contact the ITS Service Desk or submit a service request by clicking the Request Service button.

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