Software Failing to Install Through Software Center

Issue/Question

When I try to install an application from the Software Center app, it fails. Clicking the Failed status text displays an error:

Unable to download the software

There was a problem downloading the software. You can try starting the installation again or if the problem continues, the information shown in the section below can assist your helpdesk in troubleshooting.

Click OK to return to Software Center.

More information

The software change returned error code 0x87D00607(-2016410105).

Cause

This error occurs if the device is not connected to WKU's network (e.g. a wired Ethernet connection on campus, WKU-SECURE, or using the VPN when off campus) or if it is connected to WKU-GUEST.

Resolution

  1. Check your network connection to ensure it is connected to WKU's network. If off campus, connect to the VPN.
  2. Quit the Software Center app.
  3. Click  Start.
  4. Search for and open Control Panel.
  5. Ensure View by is set to Large icons or Small icons.
  6. Open Configuration Manager.
  7. Select the General tab.
  8. Locate the Connection Type: property.
    • If Currently Internet is displayed, the Software Center app will not install applications.
    • If Currently Intranet is displayed, the Software Center app will install applications as intended.
    Note: The Connection Type: property does not automatically refresh. Close and reopen the Configuration Manager Properties window to verify the field is updated.
  9. Within 5 minutes of establishing a connection with WKU's network, Currently Intranet will display.
  10. Return to the Software Center app and attempt to install the software again.
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