Issue/Question
How can I send large / secure files?
Environment
- WKU Faculty/Staff/Students
Cause
WKU ITS does not recommend sending sensitive or overly large files via email and provides a utility to deliver such. Email is a convenient way to send information but is not very secure. Servers handling email don't always use encryption and can store data and attached files for a long time with little oversight to the safety of their contents. Using the WKU Secure Share application, you ensure files are only stored until the recipient retrieves them. The utility can also send files too large for email to handle. Files are stored securely for 5 days before they are automatically purged.
Resolution
At least one file must be attached in order to use this system. You cannot send a message by itself using this system.
Alumni, retirees, and external users can receive files and send to @wku.edu, @topper.wku.edu, and @mail.wku.edu domains only. Entering any other domain address will generate an error listing the address and state at least one invalid email address.
Faculty / Staff can send multiple files up to 2 GB in size, total. Students can send multiple files up to 300 MB in size, total, using the WKU Secure Share tool. To send more attachments than can fit in one message you must send multiple messages.
The WKU Secure Share tool has an overall quota of 2 GB for faculty / staff and 300 MB for students. This is a cumulative total for all messages sent until additional space has been cleared. If you need additional space to send a message after it has already been sent, please see Recovering Storage Space below.
Sending a Message
- Go here.
- Enter your WKU Account and Password.
Note: You will have to approve your login via a multi-factor option. If you do not have a multi-factor application installed or configured on your smartphone you will be asked to complete that process at this time before being able to continue forward.
- Browse for the file(s) you want to send by clicking Add Files... button.
Note: The following file types are not allowed to be sent: exe, vbs, pif, scr, bat, cmd, com, cpl.
- Enter address(s) to which you want to send.
Note: There can be multiple email address in the Send to: line. Separate addresses with a comma followed by a space. All emails included will be visible to all recipients unless you select to email using the add bcc button.
- Enter Subject.
- Enter Message.
- Check the box to send a copy to yourself if you would like to receive a copy of the message.
- Click Send.
Recovering Storage Space
- Go here.
- Enter your WKU Account and Password.
Note: You will have to approve your login via a multi-factor option. If you do not have a multi-factor application installed or configured on your smartphone you will be asked to complete that process at this time before being able to continue forward.
- Click Secure Messages at top of page.
- Select Sent.
- Find message with attachment you wish to delete.
- Click downward chevron in action column.
Note: You may have to scroll down with mouse or use keyboard arrows to display all options under action column after clicking chevron.
- Select Delete Attachments.
Note: Attachments will be deleted and recipient(s) will no longer be able to download them. There is no way to undo this action. If files need to be sent again, a new message will have to be composed and sent.