Requesting VPN Access

Issue/Question

How do I request Cisco Secure Client VPN access?

Cause

Cisco Secure Client VPN is used for accessing special ITS sites and systems remotely and securely.

Resolution

Faculty and Staff are granted VPN access automatically upon employment. If you are needing to install the VPN on your device, please click here for instructions to install and configure. 

You will need to provide the following information:

  • The operating system of the device you'll be using.
  • If you own a smart phone and the cell phone number.
  • What IT sites/systems you need to access.
  • If the device is personal or WKU-owned.
  • Your supervisor's name.

Please contact the ITS Service Desk or submit a service request by clicking the Request Service button if you are needing to request VPN access for student workers.

Request Service Print Article

Related Articles (6)

Instructions for setting up Cisco Secure Client VPN in macOS.
Instructions for setting up Cisco Secure Client VPN in Windows.
Instructions on getting assistance with AppXtender issues.
Instructions for logging in to InfoView.
Instructions for mapping the Z:\ for CEC / Communications Sciences and Disorders access.
Instructions on what to do when you get a network error when access electronic imaged documents (e.g., student transcript) through TopNet.

Related Services / Offerings (1)

Do you have an issue or request involving cyber security on your account, computer, device, or server (ex., compromised system, VPN, MFA, guest accounts, firewall, secure data recovery, and so on)?