Sending Secure or Large Files

Issue/Question

How can I send large / secure files?

Environment

  • WKU Faculty/Staff/Students

Cause

WKU ITS does not recommend sending any sensitive or overly large files via email, and provides a send files securely facility. Email is a very convenient way to send information over the internet, but it is not very secure. Servers that handle email don't always use encryption and can store data and attached files for a very long time with little oversight to the safety of their contents. By using the WKU Secure Share application, you ensure that the files are only stored until the recipient retrieves it. The application can also be used to send files that are too large for email to handle. The files are stored securely for 5 days until they are automatically purged and no longer accessible. 

Resolution

At least one file must be attached in order to use this system. You cannot send a message by itself using this system. 
Faculty / Staff can send multiple files up to 1 GB in size, total. Students can send multiple files up to 300 MB in size, total, using the WKU Secure Share tool. If you need to send more attachments than can fit in one message you will have to send multiple messages with fewer attachments per message.
The WKU Secure Share tool has an overall quota of 1 GB for faculty / staff and 300 MB for students. This is a cumulative total for all messages sent until additional space has been cleared. If you need additional space to send a message after it has already been sent, please see the additional steps below

Sending a Message

  1. Go here.
  2. Enter your NetID and Password.
    Note: You will have to approve your login via a multi-factor option. If you do not have a multi-factor application installed or configured on your smartphone you will be asked to complete that process at this time before being able to continue forward. 
  3. Browse for the file(s) you want to send by clicking the Add Files... button. 
    Note: The following filetypes are not allowed to be sent: exe, vbs, pif, scr, bat, cmd, com, cpl.
  4. Enter the address(s) you want to send to.
    Note: There can be multiple email address in the Send to: line. Separate the addresses with a comma followed by a space. All emails included will be visible to all recipients unless you select to email using the add bcc button.
  5. Enter Subject.
  6. Enter Message.
  7. Check the box to send a copy to yourself if you would like to receive a copy of the message. 
  8. Click Send

Recovering Storage Space

  1. Go here.
  2. Enter your NetID and Password.
    Note: You will have to approve your login via a multi-factor option. If you do not have a multi-factor application installed or configured on your smartphone you will be asked to complete that process at this time before being able to continue forward. 
  3. Click Secure Messages  at the top of the page. 
  4. Select Sent
  5. Find the message with the attachment you wish to delete. 
  6. Click the downward chevron  in the action column. 
    Note: You may have to scroll down with the mouse or use the keyboard arrows to display all options under the action column after clicking the chevron. 
  7. Select Delete Attachments.
    Note: The attachments will be deleted and the recipient will no longer be able to download them. There is no way to undo this action. If the files will need to be sent again, a new message will have to be composed and sent to the recipient. 
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