WKU Account Email Access Timeline

Issue/Question

Why can I not find or access my student email (TopperMail) account credentials?

Cause

Student WKU Accounts (TopperMail) are not provisioned until student is fully admitted.

Resolution

Students (including Dual-Credit) applying to the University have email accounts created within 24 hours of being admitted to WKU.

If you need assistance, please contact the ITS Service Desk or submit a service request by clicking the Request Service button.

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Related Services / Offerings (1)

Do you have an issue or request involving employee or TopperMail email or a Microsoft 365 application?