Experiencing Wi-Fi Problems

Issue/Question

I am having problems connecting to the WKU Wi-Fi networks, what should I do? 

Environment

  • WKU-WIRELESS
  • WKU-SECURE
  • WKU-GUEST

Cause

There are several reasons that you may be unable to connect to WKU Wi-Fi networks. Please see common troubleshooting steps outlined below.

Resolution

If your laptop will not connect to the network anywhere on campus after trying these steps, it may be best to have WKU TopperTech assist in determining the cause. If you continue to experience problems, please contact the ITS Service Desk or submit a service request by clicking the Request Service button.
  1. Try forgetting the WKU network on your device, and then reconnecting:
  2. Make sure your device is using DHCP:
  3. Restart the device that you are using and try to connect again. 
Request Service

Details

Article ID: 3257
Created
Thu 4/4/19 1:00 PM
Modified
Fri 8/18/23 6:29 PM

Related Articles (3)

Instructions for checking that a Windows computer is using DHCP.
Instructions for checking that a macOS computer is using DHCP.
Information about WKU's wireless network and what to do if you are having Wi-Fi issues.

Related Services / Offerings (1)

Do you need to report an issue with WKU’s Wi-Fi?