Issue/Question
When I try to interact (open/copy/move/edit/save/etc) with a file on a WKU network drive (Personal, Shared, Secure), a Finder window displays something similar to
Preparing to copy file
The window will not progress nor cancel and I have to restart for it to go away.
Environment
- macOS
- Files on a network drive, such as the P:\ or S:\.
Cause
macOS, by default, creates metadata files on network drives intended to browse folders quicker but can cause Finder to become unresponsive on enterprise-level network drives, such as WKU's.
Resolution
- This issue has been resolved automatically for Macs enrolled in our device management solution. See this article for information on enrolling your WKU-Owned Mac.
- Click (Spotlight).
- Search for and open Terminal.
- Enter
defaults write com.apple.desktopservices DSDontWriteNetworkStores -bool TRUE
- Press Return.
- Restart your computer.