Update Server Connection Error

Issue/Question

When I try to open the Respondus Lockdown Browser I receive this error message:

Update server is not supplying information, or the connection to update server is blocked. Please try again later.

Cause

There are many possible reasons for receiving this message, e.g. a network connection error, a conflicting proxy setting, or an application blocking access to the Respondus servers.

Resolution

  1. Ensure your network connection is working properly. Reference the Related Article, Receiving No Network Connection, for assistance.
  2. To check for proxy settings, reference the applicable Related Article, Clearing Proxy Server Settings, for your operating system.
  3. Add the following addresses to the Trusted Sites list on your computer to ensure the Respondus servers are not blocked. See Related Article, Adding Trusted Sites, for assistance.
    • respondus2.com
    • respondus.com
    • static-public-downloads-cloud.respondus.com.s3.amazonaws.com
  4. If the issue persists, it is recommended to try using the Respondus browser either on a different computer or on a different network. This will help determine if the issue is specific to your computer or a broader issue that needs further investigation.

If the above steps do not resolve your problem, please contact the ITS Service Desk.

Details

Article ID: 961
Created
Tue 12/2/14 12:43 PM
Modified
Mon 3/25/19 1:03 PM

Related Articles (3)

Instructions for adding trusted sites to Internet Explorer.
Instructions for changing proxy settings on Windows 8 computers.
Information about receiving no network connection errors.