Shared Mailbox Deleted Items Stored in Personal Account Deleted Items

Issue/Question

When I delete an email from a shared mailbox account, like wku.department@wku.edu, the deleted message goes to my personal account's deleted items folder. 

Environment

  • Windows
    • Outlook 

Cause

This is the intended behavior for shared mailbox accounts from Microsoft. However, many people would prefer that the deleted items from the shared mailbox remain in the folders of the shared mailbox. Please see the steps below to restore the deleted items to the shared mailbox. 

Resolution

Do not follow these steps if you are using Outlook on a Mac. These steps are not needed on macOS and are for Windows computers only.
  1. Open Outlook. 
  2. Go to the shared mailbox account. 
  3. Select the Deleted Items folder. 
  4. Click the Recover items recently removed from this folder link at the top of the Deleted Items list. 
  5. The messages that have been deleted by other people, but exist in their personal Deleted Items folder will be listed here. 
  6. Select the message(s) that you would like to restore to the Deleted Items folder of the shared mailbox. 
  7. Click OK.
    Note: This will restore a copy of the message to the shared mailbox Deleted Items folder. The original deleted item will remain in the Deleted Items folder of the person who deleted the message. 

If the messages have been restored to the shared mailbox Deleted Items folder are deleted again, there is a window of 14 days to recover the message. Please contact the ITS Service Desk or submit a service request.

Print Article

Details

Article ID: 3773
Created
Wed 3/10/21 8:25 AM
Modified
Thu 10/26/23 1:42 PM

Related Articles (1)

Instructions for accessing shared mailbox accounts after migration to Microsoft 365.